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Tutorial 4: Building Tangency with B-splines

Overview
In this tutorial, we will demonstrate the end tangency principle of B-spline Curves
and show you how to create durable tangency relationships between two ends of a
single curve or surface, and between two different curves or surfaces. After finishing
each section, close the model files without saving the changes.

Entity introductions:
➢ More B-spline Curve
➢ More B-spline Lofted Surface
➢ Line
➢ Mirrored Curve
➢ Mirrored Point
➢ Mirrored Surface
➢ Projected Curve
➢ Projected Point

Concept and Function introductions:
➢ B-spline Curve ending normal to plane plus mirror symmetry makes G2 join.
➢ B-spline Curve is tangent to the line between its end and next-to-end control

points
➢ B-spline Lofted Surface ends normal to plane if 2nd last curve is projected onto

plane of symmetry
➢ B-spline Lofted Surface with 2 control curves is ruled surface
➢ Ctrl+shift+click adds second instance of entity to Selection Set
➢ Double Click entity edit dialog
➢ G1 continuity
➢ G2 continuity
➢ Select B-spline Curve points in spatial order
➢ Tangency across a Mirrored Point
➢ Tangency between 2 arbitrary B-spline Lofted Surfaces
➢ Tangency between B-spline Curve and Line
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Here are the basic steps we’ll follow:

• Create durable relationships between two ends of a curve or surface.
• Show curve tangency by displaying polylines.
• Connect the ends of a B-spline curve into a smooth loop.
• Make the end points of a spline normal to a plane, and mirror that spline.
• Take the concepts learned about curves and apply them to surfaces.
• Make two independent surfaces tangent to one another.

For this tutorial and the rest of the tutorials it is assumed that you already know
something about using SurfaceWorks and that you are familiar with the basics of
inserting entities, modifying the display of the model, etc.  If you do not understand
how to perform a task, you should probably look at the earlier tutorials.

B-spline Curves: The Endpoint Tangency Property
We’ll begin by demonstrating one of the tangency properties of B-spline Curves: at
each endpoint, they are tangent to the line between the end and next-to-end control
points.

1 In SolidWorks, File>Open TANGENT1.sldprt from \Integrated Tutorials.

2 Choose SurfaceWorks>Modeler.

Check program settings
Let’s check those program settings and make sure we’re all starting with the same
ones (the initial program defaults). This is what you should have:

On the View menu:

Status Bar should be ON (preceded by a checkmark; to turn an option on,
simply click on the menu item or if it has a box next to it click on the box).

All Toolbars should be ON.  To check this, click on Toolbars.  The resulting list
should have all of its boxes checked.

On the Tools>Options, General, tab:

Rotation Constraint should be set to Free tumble

On the Tools>Options, Dragging tab:

All the snaps should be ON

Prompt after drag should be OFF (no checkmark)

The B-spline Curve
So far, this model consists solely of seven points. We will use them as control points
for a B-spline Curve.

1  (View>Nametags, Point).
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2 Put points ‘pt1’ through ‘pt7’ into the Selection Set.  (In this instance, if you
drag a box around all of them, they will all end up in the Selection Set in order).

It’s important for a B-spline Curve to select the points in spatial order; it happens in
this case that they’re named in sequential order, but this won’t always be true.

3 >B-spline Curve or Insert>Curve>B-spline Curve.  OK to accept all the
defaults.

Now, we’ll make lines between the end and next-to-end control points to help
visualize the end tangencies.

4 Put ‘pt1’ and ‘pt2’ into the Selection Set.

5 >Line.  OK to accept the defaults.

6 Select ‘pt7’ and ‘pt6’.

7 Press <F4> to make another Line (Fig. 1). The ends of ‘curve1’ are tangent to
‘line1’ and ‘line2’. This is one of the tangency principles of a B-spline Curve: it is
tangent to the line between its end and next-to-end control points. This should
match our distribution model TANGENT2.sldprt.

Fig. 1

Note that a B-spline Curve does not pass through its control points (except its end
ones), but acts as if attracted to them or attached to them with springs.

8 Drag one of the interior (non-end) control points around and watch how the
curve responds.

9 Undo any changes you made in step 8.

The Polyline Display
We’ll show you another way you can visualize this tangency:

1 Hide ‘line1’ and ‘line2’.  Try right-clicking on each line and selecting 'Hide'.

2 Double-click ‘curve1’ to get its Edit dialog.

3 On the Display tab, check the Polyline check box.  OK (Fig. 2).



Tutorial 4: Building Tangency with B-splines Tangency and B-spline Curve Loops

4-4   •   SurfaceWorks for SolidWorks Tutorials January 14, 2002

Fig. 2

With the polyline displayed you can visualize the tangency at the ends of B-spline
Curves.  Drag one of the end points and watch the polyline remain tangent to the
end of the curve.

With this image on the screen, we’d also like to point out that the B-spline Curve
makes a smooth imitation of the polyline shape. This is one of its key design
properties.

4 Close this part, don’t save changes.

Tangency and B-spline Curve Loops
We’ll use the next model to demonstrate how you can construct a B-spline loop that
is durably smooth across the joining ends. We do this by constructing the ends so
they are tangent to the same line.

1 In SolidWorks, File>Open LOOP1.sldprt from \Integrated Tutorials.

2 Choose SurfaceWorks>Modeler.
Here again we want to select all the points in the model, in order, and use them to
make a B-spline Curve. Since the points are named sequentially, here’s another way
we can select them:

3  or <Ctrl+A> to select all the points.

4  (View>Nametags, Point).

In the Selection Set pane, notice that the points are listed sequentially from ‘pt1’ to
‘pt5’ — that’s the order we want them in for the curve we’re creating, so we can
proceed without having to reorder them in the Selection Set.

5 >B-spline Curve and OK to accept the defaults.

6 Select ‘pt1’ and ‘pt5’ and make a Line between them (see Fig. 3 below).
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7 With the Line still selected, click  and place a bead on the line near its
middle.  Return to Select Mode.

Fig. 3

Add the Bead as a Control Point
Now we’ll add this bead as the first and last control point for the B-spline Curve:

1 Double-click ‘curve1’ to edit its definition. The Control points field is active
(salmon) by default, so we can proceed immediately to adding control points:

2 In the graphic image or in the Available Entities pane, Ctrl+click ‘bead1’, and
then Ctrl+shift+click ‘bead1’ again — this adds ‘bead1’ twice to the Selection
Set of control points for the curve.

3 In the Selection Set pane, highlight one of the ‘bead1’ entries, then use  to
move it to the top of the list.

4 Click OK (Fig. 4). This should match our distribution model LOOP2.sldprt in
Home View.

Fig. 4

5 Drag ‘pt1 or ‘pt5’ around (e.g. Fig. 5). The loop remains closed and the
curvature remains smooth across ‘bead1’.
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Fig. 5

6 Now, drag ‘bead1’ back and forth on its line. Again, the loop remains closed
and the curvature remains smooth across ‘bead1’.  As the bead nears the end of
the line, the tangency requirement forces one end to become nearly
perpendicular to the line and then to form a sharp point in the B-spline curve,
making it anything but smooth.  If model requirements demand the placement of
the bead further out along the line but you still want the rounded shape, try
lengthening the line first and then moving the bead to the proper location.

We’ve used the tangency property of the ends of a B-spline curve to our advantage.
We know that the end of the spline is tangent to a line between the last two control
points. If both ends of the spline share the same line, both ends will be tangent to the
line and to each other.

7 Close the part; don’t save changes.

Tangency Between a B-spline Curve and a Line
This time, we will construct the model so that only one end of the B-spline Curve is
tangent to the Line. To do this, we will change the control points on each end of the
B-spline Curve and then pull the bead out beyond the end of the Line, onto the
extension of the Line.

1 In SolidWorks, File>Open LOOP2.sldprt from \Integrated Tutorials.

2 Choose SurfaceWorks>Modeler.
3 Edit the definition of ‘curve1’.

4 In the Selection Set pane, highlight ‘pt5’, then click  to remove it from the list
of control points.

5 Still in the Selection Set pane, remove the second instance of ‘bead1’.

6 At the top of the list, highlight the first instance of ‘bead1’, then click  to move
it into second position in the list.

7 In the Edit dialog, click OK.
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Fig. 6

The curve has developed an S-curve (Fig. 6), but we’re not quite done with it yet. We
need to put the bead into position:

8 Select ‘bead1’ and drag it off the end of the line to the right (Fig. 7). Now
you can see that the end (‘pt1’) and next-to-end (‘bead1’) control points of the B-
spline Curve are in line with the Line, thus making the B-spline Curve tangent to
the Line. This join is G1 — there is continuous slope at the join. (To make the join
G2 — continuous slope AND curvature, you could add another bead on the line
and include it, in sequence, as another control point for the B-spline Curve.)

Depending on how far off the line you dragged the bead, your model should now
resemble the distribution model TANCURVELINE.sldprt.

Fig. 7

8 Drag ‘bead1’ back and forth along the extension of the line. Notice that the
farther right you drag the bead, the smoother the transition between the line and
the B-spline.

9 As with the previous example, you can move the endpoints of the line and the
tangency between the line and the B-spline will be maintained (e.g. Fig. 8). Try it.
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Fig. 8

10 Close the part; don’t save changes.

Tangency and Mirrored Curves
In this example, we’ll use Projected Points to make a B-spline Curve end
perpendicular to a plane, then we’ll mirror that curve across the plane. The B-spline
Curve and its Mirrored Curve will join durably and smoothly across the plane.

1 In SolidWorks, File>Open TANPLANE1.sldprt from \Integrated Tutorials.

2 Choose SurfaceWorks>Modeler.
3 Select ‘pt1’.

4 >Projected Point or Insert>Point>Projected Point.
Name = 'pt5' (default)
Point = 'pt1' (pre-selected)
Mirror = ‘xpl0’.
OK

5 Now put ‘pt4’ and ‘xpl0’ into the Selection Set and press <F4> to make another
Projected Point.  OK to accept the defaults.  (Fig. 9).

Fig. 9
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Add the Projected Points as Control Points
We’ll add these two Projected Points as the first and last control points of the B-
spline Curve, thus making the B-spline ends meet the plane perpendicularly:

1 Double-click ‘curve1’.
2 Add ‘pt5’ and ‘pt6’ to the set of Control points.

3 In the Selection Set pane, select ‘pt5’, then use  to move it to the top of the
list.

4 In the Edit dialog, click OK (Fig. 10).

Fig. 10

Make a Mirrored Curve
Now for the Mirrored Curve:

1 Place ‘curve1’ and 'xpl0' in the Selection Set.

2 >Mirrored Curve or Insert>Curve>Mirrored Curve.  OK to accept the
defaults.

3  (Zoom to Fit) (Fig. 11)  This should match our distribution model
TANPLANE2.sldprt .

Fig. 11
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In this case, we’ve made both ends of a B-spline normal to a plane, then mirrored
that spline across the plane, resulting in a loop completely symmetric and smooth.
The combination of the B-spline Curve ending normal to the plane plus the mirror
symmetry makes the joins G2 — continuous slope and curvature.

4 Close the part; don’t save changes.

Tangency and Mirrored Points
In this example, we’ll use Mirrored Points to establish tangency between both ends
of two B-spline Curves, making a very flexible loop.

1 In SolidWorks, File>Open TANPOINTS1.sldprt from \Integrated Tutorials.

2 Choose SurfaceWorks>Modeler.

3 Select ‘pt2’, and make a >Mirrored Point or Insert>Point>Mirrored Point.
Name = 'pt5' (default)
Point = 'pt2' (pre-selected)
Mirror = ‘pt1’.
OK

4 <F> (Zoom to Fit).

5 Make a second Mirrored Point, this time using 'pt3' as the Point and ‘pt4’ as the
Mirror.

6 Select ‘pt1’, ‘pt5’, ‘pt6’, and ‘pt4’ in that order.

7 Make a >B-spline Curve. Check that the control points are listed in the
correct order (if they are not, select them again now).  OK to accept defaults
(Fig. 12). This should match our distribution file TANPOINTS2.sldprt .

Fig. 12
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8 Drag ‘pt2’ and notice that the tangency is maintained at ‘pt1’. Similarly, if you
were to drag ‘pt3’, tangency would be maintained at ‘pt4’.  Notice that you
cannot drag the two Mirrored Points 'pt5' and 'pt6'.

9 Close the model; don’t save changes.

Tangency Between Surfaces
Everything we’ve said about B-spline Curves so far can be applied to B-spline Lofted
Surfaces as well. Just as the B-spline Curve is tangent to the line between the end and
next-to-end control points, the B-spline Lofted Surface is tangent to the imaginary
ruled surface between the last two control curves.

1 In SolidWorks, File>Open TANSURFACE1.sldprt from \Integrated Tutorials.

2 Choose SurfaceWorks>Modeler.

3 Select the upper curve (‘xcv7’) and the plane, then make a >Projected
Curve or Insert>Curve>Projected Curve.  OK to accept all defaults.

4 Select the lower curve (‘xcv14’) and the plane, and make another Projected
Curve.  OK to accept all defaults. (Fig. 13).

Fig. 13

Now, when we loft a B-spline lofted surface over these curves — the upper Projected
Curve, the upper spline, the lower spline, and the lower Projected Curve — the
lofting B-splines that pass through each of the four control curves will end normal to
the plane. Let’s do it:

5 Select ‘xcv15, ‘xcv7’, ‘xcv14’, and ‘xcv16’ in that order.

6 (the one with the cyan control curves)>B-spline Lofted Surface or
Insert>Surface>B-spline Lofted Surface.  OK to accept all defaults.

A Mirrored Surface of this B-spline Lofted Surface will also end normal to the plane
and, therefore, make a smooth join with the first surface:

7 With ‘surface1’ in the Selection Set, add the plane.
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8 (the one with the all blue boundary)>Mirrored Surface or
Insert>Surface>Mirrored Surface.  OK to accept all defaults.  (Fig. 14).  This
should match TANSURFACE2.sldprt .

Fig. 14

9 Close the model; don’t save changes.

Tangency Between Two Arbitrary B-spline Lofted Surfaces
This final Tutorial 5 example demonstrates how to make two arbitrary B-spline
Lofted Surfaces tangent to each other. To build a durable tangency relationship, we’ll
use two Relative Curves, the second based on mirrored endpoints of the first.

1 In SolidWorks, File>Open TWOSURFACES1.sldprt from \Integrated
Tutorials.

2 Choose SurfaceWorks>Modeler.

3  to show Curve Nametags.

To give you an idea of where we’re headed: ‘xcv7’ and ‘xcv24’ will be the edge
control curves for one B-spline Lofted Surface and ‘xcv15’ and ‘xcv24’ will be the
edge control curves for another. We’ll begin by making a Relative Curve to control
the tangency of the upper surface-to-be.

The First Relative Curve

1  (View>Nametags, Point).

2 Select ‘xpt17’ (at the left end of the middle curve), then >Point or
Insert>Point>Point.

Name = 'pt23'
Offsets:  dx=dy=dz=0 (default)
Point = 'xpt17' (pre-selected)
Frame = * (default)
OK
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3 This puts the new Point at dx = 0, dy = 0, dz = 0, which is right on top of its
parent ‘xpt17’.

4 Drag the new point (‘pt23’) about 1/4 the distance toward ‘xpt0’ (at the end of
the uppermost spline; see Fig. 15 below).

5 Select ‘xpt22’ (at the other end of the middle curve), and make another Point.
Name this point 'pt24'.  OK.

6 Drag the new point (‘pt24’) toward ‘xpt5’, about the same distance and in the
same direction that you dragged ‘pt23’ (Fig. 15).

'pt23'

'pt24'

Fig. 15

Remember that a Relative Curve should have the same entity orientation as its
parent curve — that is, its starting point should be the point offset from the parent
curve’s starting point (and its ending point should be the point offset from the parent
curve’s ending point).

7 Select ‘xcv24’ (the middle curve).  Now we know the orientation of the parent
curve.

8 With ‘xcv24’ still selected, add ‘pt23’ and ‘pt24’ to the Selection Set, in that order
(you should now have three entities selected).

9 >Relative Curve or Insert>Curve>Relative Curve.
Name = 'relcvupper'
Curve = 'xcv24' (pre-selected)
Point1 = 'pt23' (pre-selected)
Point2 = 'pt24' (pre-selected)
OK (Fig. 16).
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Fig. 16

The Upper B-spline Lofted Surface
Now we’re ready to make the first B-spline Lofted Surface:

1 Select ‘xcv7’, 'relcvupper', and ‘xcv24’ in that order. These will be the control
curves for the upper B-spline Lofted Surface.

2 >B-spline Lofted Surface.  OK to accept all defaults.

To visualize the tangency here, let’s make the ruled surface between the last two
control curves:

3 Select 'relcvupper' and ‘xcv24’.

4 >B-spline Lofted Surface (a B-spline Lofted Surface with just two control
curves is a ruled surface).

Display>Color = Brown
Advanced>u-divisions = 8x4
Advanced>v-divisions = 1x4
OK

5 Click on point 'xpt17',  and rotate the model.  With the two surfaces end-on
you should be able to see that ‘surface1’ ends tangent to the new surface (Fig.
17).

'surface2'
'surface1'

  Fig. 17  Lat 1.7, Lon -52, Tilt 59.5
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6 In Select mode, drag ‘pt23’ around a bit and watch how the B-spline Lofted
Surface responds, while always maintaining tangency to the ruled surface.

7 Undo the changes made in step 6.

The Second Relative Curve
Now let’s work on the lower surface, beginning by making a Relative Curve that will
control its tangency.

1  (Home view).

2 With ‘pt23’ (at the left end of ‘curve1’) still selected, make a >Mirrored
Point.

Name = 'pt25'
Point = 'pt23' (pre-selected)
Mirror = ‘xpt17’
OK

3 Select ‘pt24’ and ‘xpt22’ in that order and make a second Mirrored Point.
Name = 'pt26'
Point = 'pt24' (pre-selected)
Mirror = ‘xpt22’ (pre-selected)
OK

Now we’ll make a second Relative Curve, also with the same entity orientation as
‘xcv24’.

4 Select ‘pt25’ and ‘pt26’, in that order, and ‘xcv24’ and make another Relative
Curve .  Name this Relative Curve 'relcvlower'.  OK (Fig. 18)

Fig. 18

The Lower B-spline Lofted Surface
1 Select ‘xcv15’, ‘relcvlower’, and ‘xcv24’ in order. These will be the control

curves for the lower B-spline Lofted Surface.

2 >B-spline Lofted Surface.  OK.

For visualization, let’s extend the ruled surface straight through to the second
Relative Curve:
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3 Edit the (brown) surface (‘surface2’).

4 In the Edit dialog, the “Control curves” field is active. In the graphic image or
in the Available Entities pane, add ‘relcvlower’; OK to the Edit dialog (Fig. 19).
(This surface started as a ruled surface because it was a B-spline Lofted Surface
with two control curves.  In general, a B-spline Lofted Surface with more than
two control curves is not ruled.  In this case, however, because of the way the
three parent curves are related, this is still a ruled surface).  Both ‘surface1’ and
‘surface3’ are tangent to this surface (‘surface2’). This join is G1 — continuous
slope.

'surface1'
'surface2'

Fig. 19  Lat 3.6, Lon -62.2, Tilt 57.5

5 Drag ‘pt23’ (or ‘pt24’) around and watch the surfaces adjust, all the while
maintaining tangency at their join.  You’ll probably have to rotate and zoom to
get the best view.  Cool.

6 Close without saving and exit.


